RSS not working

Post Reply

user_16560 February 27, 2021 11:00 AM
Posts:
7
Join Date:
Feb 2021
The rss link is not being accepted by the software(RSSBot), and it returns with the message - "Hmm, I couldnt find an RSS feed for that URL. Hit back to make sure we're using the right URL"
Reply
admin February 27, 2021 4:03 PM
Posts:
620
Join Date:
Dec 2010
Hi, could you please provide a link to the RSSBot software? Thank you!
Reply
user_16560 February 28, 2021 2:01 AM
Posts:
7
Join Date:
Feb 2021
https://apps.apple.com/us/app/rss-bot-news-notifier/id605732865?mt=12? This is the link Smile
Reply
user_16560 February 28, 2021 2:10 AM
Posts:
7
Join Date:
Feb 2021
When using another software (feedy) it shows the message "Failed to update feed: the network connection was lost".
Reply
admin February 28, 2021 2:28 PM
Posts:
620
Join Date:
Dec 2010
Hi, just checked both of those RSS clients and they work as expected. Have you copied the right RSS URL? This should not be shared publicly and it should look like: https://www.camnotifier.com/mycams/rss/[hash]/rss.xml

To test it, after setting the feed URL up, add to monitoring a cam that's already online, you should then receive a notification. Could you share a screenshot of how you have set this up and please make sure you hide your RSS feed URL.

Thank you!
Reply
user_16560 February 28, 2021 2:49 PM
Posts:
7
Join Date:
Feb 2021
Originally Posted by admin
Hi, just checked both of those RSS clients and they work as expected. Have you copied the right RSS URL? This should not be shared publicly and it should look like: https://www.camnotifier.com/mycams/rss/[hash]/rss.xml

To test it, after setting the feed URL up, add to monitoring a cam that's already online, you should then receive a notification. Could you share a screenshot of how you have set this up and please make sure you hide your RSS feed URL.

Thank you!


Yep, will do!!
Reply
user_16560 February 28, 2021 3:03 PM
Posts:
7
Join Date:
Feb 2021
Ummm, it appears that since i added another cam to monitor the rssfeed started working again.....
Sorry for wasting your time :'')
Reply
admin February 28, 2021 10:29 PM
Posts:
620
Join Date:
Dec 2010
Glad to hear it is working, no worries!
Reply
user_16560 March 14, 2021 11:25 AM
Posts:
7
Join Date:
Feb 2021

Hi me again!

It seems that the rss stopped working yet again.... When using RSS Bot, a message is shown when you try to add the the feed ---->
Processing Error
Hmm, I couldnt find an RSS feed for that URL. Hit back to make sure we are using the right URL.
Reply
user_16560 March 14, 2021 11:25 AM
Posts:
7
Join Date:
Feb 2021
Originally Posted by user_16560
It seems that the rss stopped working yet again.... When using RSS Bot, a message is shown when you try to add the the feed ---->
Processing Error
Hmm, I couldnt find an RSS feed for that URL. Hit back to make sure we are using the right URL.

The URL is right though....
Reply
admin March 16, 2021 4:33 AM
Posts:
620
Join Date:
Dec 2010
Hi, just testing these RSS clients myself and I cannot reproduce the issue. Any chance you could provide a screenshot of the actual error message and also provide some details about your operating system and send these to [email protected]

Or use the support option on the contact page: https://www.camnotifier.com/page/contact

Thank you!
Reply
admin March 16, 2021 10:42 AM
Posts:
620
Join Date:
Dec 2010
I could find some issue with these clients (RSS News Notifier and Feedly), they do not notify for the same cam going live a second time. I believe they look at the cam URL when determining if the "article" is unique. Will have to include in the cam URL a timestamp parameter to make this work.
Reply
Placid May 27, 2021 10:53 AM
Posts:
1
Join Date:
May 2018

No RSS notification after the first one

Originally Posted by admin
Will have to include in the cam URL a timestamp parameter to make this work.


Is there an ETA for this?

I guess that issue of nothing-after-first-notification is reproducible on any of RSS clients in existence.

I got this problem with newsboat (CLI) and Feedbro (Firefox). First notification happens and then nothing... I second that a timestamp parameter would help the RSS client to differentiate new from old cam URLs.

Is your code on github? I could eventually sent a PR
Reply
admin May 27, 2021 5:15 PM
Posts:
620
Join Date:
Dec 2010
Hi! No, the code is not open sourced.

We have just made the changes and the URLs should now contain the timestamp of when the cam has been flagged as online.

Let us know if there are any issues. Will keep monitoring for a few days.
Reply
admin May 29, 2021 4:55 AM
Posts:
620
Join Date:
Dec 2010
Hi! We did a new change to the way the RSS is built, should be working as expected now. Thank you!
Reply

Post Reply

Ads